admin
Moved here from Email Supprot

Question:

I recently installed Ubuntu 12.04 LTS on my computers but I can't install the SME software. Please see the screen shot. Can you please said to me what I do wrong?

Answer:

Seems this is an unfixed bug in Ubuntu.
 
From the other information your provided I see these packages are not installed:
libxml-simple-perl
libxml-sax-perl mais
libxml-libxml-perl
libxml-sax-expat-perl
libxml-namespacesupport-perl
libqt4-core
libqt4-gui
libqt4-dev
 
You should run the following command from terminal:
 
sudo apt-get -f install



Quote
artemkolotilkin
Hi,

I think I have the same issue. Here are the steps that I took:

1. Install the package:
 
Code:
sudo dpkg -i ~/Downloads/storagemadeeasy_4.0.7.deb
Selecting previously unselected package storagemadeeasy.
(Reading database ... 142122 files and directories currently installed.)
Unpacking storagemadeeasy (from .../storagemadeeasy_4.0.7.deb) ...
dpkg: dependency problems prevent configuration of storagemadeeasy:
 storagemadeeasy depends on libqt4-core (>= 4.3); however:
  Package libqt4-core is not installed.
 storagemadeeasy depends on libqt4-gui; however:
  Package libqt4-gui is not installed.
 storagemadeeasy depends on libqt4-dev; however:
  Package libqt4-dev is not installed.
 
dpkg: error processing storagemadeeasy (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 storagemadeeasy


 
2. Install missing dependencies:
 
Code:
sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  fuse-utils g++ g++-4.7 libfilesys-statvfs-perl libfuse-dev libfuse-perl
  liblchown-perl libselinux1-dev libsepol1-dev libstdc++6-4.7-dev qt4-qmake
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  storagemadeeasy
0 upgraded, 0 newly installed, 1 to remove and 8 not upgraded.
1 not fully installed or removed.
After this operation, 3,789 kB disk space will be freed.
Do you want to continue [Y/n]?


As you can see it suggests to remove storagemadeeasy package instead of installing missing dependencies.

Can you please help to resolve that?

Thanks!
 
Quote
admin
What version of Linux and build number are you using ?
Quote
artemkolotilkin
 
Code:
(unity)artem@localhost:~$ uname -a
Linux localhost 3.8.11 #1 SMP Tue Aug 27 20:53:54 PDT 2013 x86_64 x86_64 x86_64 GNU/Linux

(unity)artem@localhost:~$ cat /etc/*-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=13.04
DISTRIB_CODENAME=raring
DISTRIB_DESCRIPTION="Ubuntu 13.04"
NAME="Ubuntu"
VERSION="13.04, Raring Ringtail"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 13.04"
VERSION_ID="13.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"


Hope it helps!
 
Quote
Igor
It looks like some troubles with repositories.

Have you tried to run this command (before install the package)?
Code:
sudo apt-get update

This command downloads the package lists from the repositories.
Quote
artemkolotilkin
Yes, I tried it before and just tried again. No luck, sorry.
Quote
Igor
Can you show screenshots with list of repositories that you use?
You can see it in Ubuntu Software Center => menu Edit => Software Sources (tabs: Ubuntu Software and Other Software)
Quote
artemkolotilkin
Here it is Click image for larger version - Name: Screenshot_from_2013-09-09_20:48:02.png, Views: 45, Size: 55.62 KB
Quote
Igor
Can you show screenshot of the tab "Ubuntu Software" ?
You can see it in Ubuntu Software Center => menu Edit => Software Sources => Ubuntu Software
Quote
artemkolotilkin
Here it is Click image for larger version - Name: Screenshot_from_2013-09-10_10:59:21.png, Views: 37, Size: 57.30 KB
Quote
Igor
Remove incorrectly installed package by the command:
Code:
sudo dpkg --remove storagemadeeasy


Did you tried to install this package via Ubuntu Software Center or GDebi? This can be done by double click or context menu on the package.
If it doesn't install then try to install missing dependencies by this command and install this package again via terminal:
Code:
sudo apt-get install libqt4-core libqt4-gui libqt4-dev
Quote
artemkolotilkin
I just tried to install only missing packages and got this:
 
Code:
sudo apt-get install libqt4-core libqt4-gui libqt4-dev[sudo] password for artem: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
 
The following packages have unmet dependencies:
 libqt4-core : Depends: libqt4-dbus (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
               Depends: libqt4-network (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
               Depends: libqt4-script (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
               Depends: libqt4-test (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
               Depends: libqt4-xml (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
               Depends: libqtcore4 (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
 libqt4-dev : Depends: libqt4-dbus (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-declarative (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-designer (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-dev-bin (= 4:4.8.4+dfsg-0ubuntu9.3)
              Depends: libqt4-help (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-network (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-qt3support (= 4:4.8.4+dfsg-0ubuntu9.3) but it is not going to be installed
              Depends: libqt4-script (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-scripttools (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-sql (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-svg (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-test (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-xml (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-xmlpatterns (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqtcore4 (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqtgui4 (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: qt4-linguist-tools (= 4:4.8.4+dfsg-0ubuntu9.3)
              Recommends: libqt4-opengl-dev (= 4:4.8.4+dfsg-0ubuntu9.3) but it is not going to be installed
              Recommends: libqtwebkit-dev (>= 2.0~) but it is not going to be installed
 libqt4-gui : Depends: libqt4-designer (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-opengl (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqt4-svg (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
              Depends: libqtgui4 (= 4:4.8.4+dfsg-0ubuntu9.3) but 4:4.8.4+dfsg-0ubuntu12~ubuntu13.04~ppa1 is to be installed
E: Unable to correct problems, you have held broken packages.
 
Quote
Igor
It looks like you have problem like this:
http://askubuntu.com/questions/140246/how-do-i-resolve-unmet-dependencies
Try this solution.
Quote

Add a Website Forum to your website.